Sitecore 9 Solr Setup - Install the Right Version of Java | Perficient Digital

Sitecore 9 Solr Setup – Install the Right Version of Java

Solr: A Sitecore 9 Prerequisite

If you are like me and followed the Sitecore 9 instructions for installing Solr (not “SOLR”), you may have noticed that “Java” is a prerequisite. If you are also like me and haven’t needed Java for anything in the last 5 years, you will need to install Java. The Sitecore installation guide simply sends you to the Solr website, which says “You will need the Java Runtime Environment (JRE) version 1.8 or higher.” If you follow the link to the Oracle site to download Java, the first thing you see is “Java SE 10.0.2 is the latest feature release for the Java SE Platform”. If you are like me and did well in math, you will realize that 10.0 is indeed higher than 1.8. Ah, but this is where you and I were so wrong. What Solr *meant* to tell you was that you need JRE 8 version 1.8 or higher.

You should use NSSM (search on it) to run Solr because you don’t actually install it, so you won’t see this error until you run it:

“Windows could not start the solr service on Local Computer. The service did not return an error. This could be an internal Windows error or an internal service error.”

Simply uninstall the new version of Java and install the 1.8 version of Java. You will be Solr-ing in no time!

Leave a Reply